SPOT Corporate - Phone System Service

Incident Report for Xplor Spot

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 07:08 MST

Identified

We are currently working to remediate service disruptions affecting the corporate phone system. At this time, the issue is impacting our Implementation and Sales teams.

If you need to reach the Sales team during this time, please contact them directly at sales@spotpos.com, and a member of the team will respond as promptly as possible.

Please note that our Support team is not affected and remains available through normal support channels.
Posted Feb 18, 2026 - 18:11 MST
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).