SPOT Corporate - Phone System Degredation

Incident Report for Xplor Spot

Resolved

This incident has been resolved.
Posted Jul 17, 2023 - 16:34 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2023 - 16:27 MDT

Update

We have applied mitigation and are now monitoring systems.
Posted Jul 17, 2023 - 16:26 MDT

Investigating

We have detected and are investigating a problem with the SPOT Corporate phone system. In the meantime, please feel free to reach out to us via the SPOT Support Portal.
Posted Jul 17, 2023 - 16:22 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).