Temporary Interruption to SPOT Cloud Services

Incident Report for Xplor Spot

Resolved

This incident has been resolved.
Posted May 18, 2026 - 18:57 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 17:26 MDT
This incident affected: SPOT Hosting Services (SPOT Application Servers, Web Service, SPOT Database Servers, Automated Conveyor Service, Kiosk Service, Connect, CustomerConnect - Web Service, CustomerConnect - Mobile Service, Dashboard Service, ProductionTrac Service, DeliveryConnect - Mobile Service, Print Service, Network Infrastructure).