SPOT Corporate Phone System Degradation
Incident Report for SPOT Business Systems
Resolved
This incident has been resolved.
Posted Jun 15, 2022 - 06:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2022 - 06:13 MDT
Investigating
We are currently investigating an issue with our sales and support phone system. If you are unable to reach us by phone, please email us at support@spotpos.com or use the Support Portal (available through the Help menu in SPOT) to create/update support cases.
Posted Jun 15, 2022 - 06:04 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Email System, Corporate Support / Sales Phone System).