Disruption in Corporate Office Services
Incident Report for SPOT Business Systems
Resolved
Power has been restored. All systems are operational.
Posted Mar 10, 2020 - 18:14 MDT
Monitoring
Corporate communication services have been restored.
Posted Mar 10, 2020 - 17:15 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2020 - 16:56 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2020 - 16:49 MDT
Identified
There is a brief power outage in communication services with our corporate office. We are working diligently to bring backup services online.
Posted Mar 10, 2020 - 16:48 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Email System, Corporate Support / Sales Phone System).