SPOT Corporate Phone System Service Degradation
Incident Report for SPOT Business Systems
Resolved
This incident has been resolved.
Posted Apr 03, 2021 - 11:33 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2021 - 11:19 MDT
Investigating
We are currently investigating an issue with our sales and support phone system. If you are unable to reach us by phone, please email us at support@spotpos.com or use the Support Portal (available through the Help menu in SPOT) to create/update support cases.
Posted Apr 03, 2021 - 10:47 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).