SPOT Corporate Phone System Degradation
Incident Report for Xplor Spot
Resolved
The phone carrier outage has been confirmed as resolved by our partners and our monitoring shows no ongoing problems with call quality.
Posted Aug 15, 2022 - 17:02 MDT
Monitoring
The carrier has implemented a fix, but we will still be monitoring for future issues. Inbound and outbound calls are functioning again.
Posted Aug 15, 2022 - 15:30 MDT
Identified
We have confirmed that a carrier outage is impacting calls going in and out from the Draper office. We are monitoring our provider for updates.
Posted Aug 15, 2022 - 12:17 MDT
Monitoring
We are seeing improvement from our provider and have been able to receive and make calls to external numbers. We will continue to monitor.
Posted Aug 15, 2022 - 11:57 MDT
Identified
We have confirmed that a carrier outage is impacting calls going in and out from the Draper office. We are monitoring our provider for updates.

Next Update: 12:00PM MDT
Posted Aug 15, 2022 - 11:28 MDT
Investigating
We are currently investigating an issue with our sales and support phone system. If you are unable to reach us by phone, please email us at support@spotpos.com or use the Support Portal (available through the Help menu in SPOT) to create/update support cases.
Posted Aug 15, 2022 - 10:53 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).