SPOT Hosted - Service Degradation

Incident Report for Xplor Spot

Resolved

The incident has been resolved, and the maintenance activity that Microsoft was performing has been rescheduled.
Posted Jul 08, 2026 - 09:48 MDT

Monitoring

At this time, the team continues to work closely with Microsoft to pause the ongoing maintenance activities. While we are beginning to see signs of improvement, the situation remains under active monitoring and assessment.
Posted Jul 07, 2026 - 11:42 MDT

Investigating

We are currently investigating with our upstream provider service degradation related to our hosted environment servers.
Posted Jul 07, 2026 - 10:37 MDT
This incident affected: SPOT Hosting Services (SPOT Application Servers, Web Service, SPOT Database Servers, Automated Conveyor Service, Kiosk Service, Connect, CustomerConnect - Web Service, CustomerConnect - Mobile Service, Dashboard Service, ProductionTrac Service, DeliveryConnect - Mobile Service, Print Service, Network Infrastructure).