Delivery Connect Route Optimization Failures

Incident Report for Xplor Spot

Resolved

This incident has been resolved.
Posted Mar 14, 2024 - 09:34 MDT

Update

We are continuing to monitor for any further issues.
Posted Mar 14, 2024 - 09:12 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2024 - 09:11 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2024 - 08:41 MDT

Update

We are continuing to investigate this issue.
Posted Mar 14, 2024 - 08:13 MDT

Investigating

We are seeing elevated rates of route optimization failures for some customers in Delivery Connect. Customers are recommended to try optimizing through Connect as we continue to investigate.
Posted Mar 14, 2024 - 07:45 MDT
This incident affected: SPOT Hosting Services (DeliveryConnect - Mobile Service).