Xplor Spot Corporate

Incident Report for Xplor Spot

Resolved

This incident has been resolved.
Posted 9 months ago. Jul 16, 2024 - 15:10 MDT

Monitoring

Our corporate office resources have been restored and our various teams are reachable again.
Posted 9 months ago. Jul 16, 2024 - 13:10 MDT

Identified

The Xplor Spot corporate office is currently experiencing a power outage and we are working to restore services. Contact with office members including our Product Support team is limited.
Posted 9 months ago. Jul 16, 2024 - 11:46 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Email System, Corporate Support / Sales Phone System).