SPOT Corporate Phone System Degredation
Incident Report for Xplor Spot
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 16:44 MDT
Monitoring
All services are now functional. Please know that we are monitoring to make sure all services remain online.
Posted Mar 21, 2023 - 15:13 MDT
Investigating
We are currently investigating an outage of services that appears to be due to widespread issues on the public internet.
Posted Mar 21, 2023 - 13:48 MDT
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).