Corporate Support / Sales Phone System Outage
Incident Report for SPOT Business Systems
Resolved
All services are fully operational at this time.
Posted 7 months ago. Jan 15, 2019 - 19:27 MST
Monitoring
We are monitoring the services as they all come back online.
Posted 7 months ago. Jan 15, 2019 - 18:14 MST
Investigating
We have identified the cause of the issue and are working on a resolution.
Posted 7 months ago. Jan 15, 2019 - 18:06 MST
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).