Corporate phone system outage
Incident Report for SPOT Business Systems
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 07:08 MST
Monitoring
After rebooting a faulty component, the phone system is once again working as expected. We will monitor for further issues, but all services should be operational at this time.
Posted Feb 25, 2020 - 06:19 MST
Investigating
We are currently investigating this issue. Technical support can be reached by email to support@spotpos.com or by the support request form on our web site at https://www.spotpos.com/support-form. We will update this incident as soon as we have more information.
Posted Feb 25, 2020 - 05:47 MST
This incident affected: SPOT Business Services (Corporate Support / Sales Phone System).